Uma área de pesquisa sobre o WordPress para devs e autores do tema



wp_maybe_grant_install_languages_cap ›

Desde4.9.0
Obsoleton/a
wp_maybe_grant_install_languages_cap ( $allcaps )
Parâmetros:
  • (array) $allcaps An array of all the user's capabilities.
    Required: Yes
Retorna:
  • (array) Filtered array of the user's capabilities.
Definido em:
Codex:

Filters the user capabilities to grant the 'install_languages' capability as necessary.

A user must have at least one out of the 'update_core', 'install_plugins', and 'install_themes' capabilities to qualify for 'install_languages'.



Fonte

function wp_maybe_grant_install_languages_cap( $allcaps ) {
	if ( ! empty( $allcaps['update_core'] ) || ! empty( $allcaps['install_plugins'] ) || ! empty( $allcaps['install_themes'] ) ) {
		$allcaps['install_languages'] = true;
	}

	return $allcaps;
}