Uma área de pesquisa sobre o WordPress para devs e autores do tema



user_can_edit_user ›

Desde1.5.0
Obsoleto2.0.0
user_can_edit_user ( $user_id, $other_user )
Parâmetros: (2)
  • (int) $user_id
    Required: Yes
  • (int) $other_user
    Required: Yes
Ver:
Retorna:
  • (bool)
Definido em:
Codex:

Can user can edit other user.



Fonte

function user_can_edit_user($user_id, $other_user) {
	_deprecated_function( __FUNCTION__, '2.0.0', 'current_user_can()' );

	$user  = get_userdata($user_id);
	$other = get_userdata($other_user);
	if ( $user->user_level > $other->user_level || $user->user_level > 8 || $user->ID == $other->ID )
		return true;
	else
		return false;
}